Tag Archives: cisco

Configure DHCP server on cisco router

tk-cisco-routers-dhcp-1

R1# configure terminal
R1(config)# service dhcp
R1(config)# ip dhcp pool NET-POOL
R1(dhcp-config)# network 192.168.1.0 255.255.255.0
R1(dhcp-config)# default-router 192.168.1.1
R1(dhcp-config)# dns-server 192.168.1.5 195.170.0.1
R1(dhcp-config)# domain-name Firewall.cx
R1(dhcp-config)# lease 9
R1(config)# ip dhcp excluded-address 192.168.1.1 192.168.1.5
R1(config)# ip dhcp excluded-address 192.168.1.10
R1# show ip dhcp binding

References :

http://www.firewall.cx/cisco-technical-knowledgebase/cisco-routers/812-cisco-router-dhcp-config.html

Cisco RIP v2 IP Routing

RIPv2-2

RouterA(config)#router rip
RouterA(config-router)#version 2
RouterA(config-router)#network 192.168.10.0
RouterA(config-router)#network 195.14.25.0
RouterA(config-router)#network 195.14.125.0
RouterA(config-router)#no auto-summary

RouterB(config)#router rip
RouterB(config-router)#version 2
RouterB(config-router)#network 192.168.20.0
RouterB(config-router)#network 195.14.25.0
RouterB(config-router)#network 195.14.125.0
RouterA(config-router)#no auto-summary

RouterC(config)#router rip
RouterC(config-router)#version 2
RouterC(config-router)#network 192.168.30.0
RouterC(config-router)#network 195.14.25.0
RouterC(config-router)#no auto-summary

References :

http://blog.pluralsight.com/cisco-how-to-configure-rip-2

Cisco RIP v1 IP Routing

RIPv1-1

RouterA(config)#router rip
RouterA(config-router)#network 192.168.10.0
RouterA(config-router)#network 195.14.25.0
RouterA(config-router)#network 195.14.125.0

RouterB(config)#router rip
RouterB(config-router)#network 192.168.20.0
RouterB(config-router)#network 195.14.25.0
RouterB(config-router)#network 195.14.125.0

RouterC(config)#router rip
RouterC(config-router)#network 192.168.30.0
RouterC(config-router)#network 195.14.25.0

References :

http://blog.pluralsight.com/cisco-how-to-configure-rip-1

Cisco Network Modules

In a nutshell:
NM-4T, has 4 serial ports for WAN connections- i believe the T stands for T1
NM-1FE-TX has 1 fast ethernet port
NM-1E has 1 ethernet port
The NM-16ESW is a switching module with 16 fast ethernet ports and provides some basic switching functionality

References :

https://community.gns3.com/thread/4665
http://www.cisco.com/c/en/us/td/docs/routers/access/interfaces/nm/hardware/installation/guide/OvrNetM.html

Cisco Router IP Traffic Export

R1>enable
R1#configure terminal
R1(config)# ip traffic-export profile MyProfile
R1(conf-rite)# interface f0/0
R1(conf-rite)# mac-address 0001.0203.0405
R1(conf-rite)# bidirectional
R1(conf-rite)# exit

R1(config)# interface s0/0
R1(config-if)# ip traffic-export apply MyProfile

R1# show ip traffic-export

References :

http://www.cisco.com/c/en/us/td/docs/ios/12_4t/12_4t11/ht_rawip.html http://packetlife.net/blog/2009/oct/26/capturing-serial-traffic-ethernet-rite/
http://keepingitclassless.net/2010/10/raw-ip-traffic-export-rite-on-cisco-ios/

Cisco cheat sheet 1

#1: The “?”

#2: show running-configuration

#3: copy running-configuration startup-configuration

#4: show interface

#5: show ip interface

#6: config terminal, enable, interface, and router

example :

configure terminal
interface fastEthernet 0/0
ip address 10.0.0.1 255.0.0.0
no shutdow
exit

#7: no shutdown

#8: show ip route

#9: show version

#10: debug